Skip to main content

Resolve Errors Installing Medusa CLI

In this document, you can find solutions to some common problems that occur when installing Medusa’s CLI Tool.

NPM Error: EACCES Permissions Errors

If you install the Medusa CLI tool with NPM and get a permission error, NPM proposes as a solution either re-installing NPM with a node version manager (nvm), or manually setting npm’s default directory.

You can check out more information in NPM’s documentation.

Yarn Error: command not found: medusa

If you install the Medusa CLI tool with Yarn, then try to use the CLI tool but get the error:

command not found: medusa
Copy to Clipboard

You have to add Yarn’s install location to the PATH variable:

Report Incorrect CodeReport Incorrect CodeReport Incorrect CodeCopy to Clipboard
export PATH="$(yarn global bin):$PATH"
Copy to Clipboard

You can learn more in Yarn’s documentation.